SELTA/MigrationPg

Материал из Etersoft wiki
Перейти к: навигация, поиск


Действия при обновлении /PostgreSQL

В этом разделе описываются действия, которые необходимо выполнить при изменении версии PostgreSQL, независимо от того, изменили ли вы при этом версию Selta. Обратите внимание, что часть из них проделывается с Selta, а часть с PostgreSQL. Если действия не указаны, значит они не требуются.



Release 9.0

  • Postgre:
Требуется выполнить операцию dump/restore, при переходе с более ранних версий.
  • Selta:
обновление баз не требуется, для всех, кто переходит с версий после 8.3.8, Если вы обновились с версии до 8.3.8, следуйте инструкциям Selta 8.3.8

Release 8.4.2 - 8.4.3

  • Postgre:
Операция dump/restore не требуется для тех, кто переходит с версий 8.4.x, но если вы переходите с версии до 8.4, следуйте инструкциям к 8.4.1
  • Selta:
обновление баз не требуется, для всех, кто переходит с версий после 8.3.8, Если вы обновились с версии до 8.3.8, следуйте инструкциям Selta 8.3.8

Release 8.4.1

  • Postgre:
Требуется выполнить операцию dump/restore, при переходе с более ранних версий.
  • Selta:
обновление баз не требуется, для всех, кто переходит с версий после 8.3.8, Если вы обновились с версии до 8.3.8, следуйте инструкциям Selta 8.3.8

Release 8.3.8

  • Postgre:
Операция dump/restore не требуется для всех, кто переходит с версий 8.3.x. Требуется выполнить операцию REINDEX.
  • Selta:
Требуется обновление баз, при переходе с более ранних версий.


Release 8.3.2 - 8.3.7

(поддерживается начиная с Selta 1.0.5)

  • Postgre:
Операция dump/restore не требуется для тех, кто переходит с версий 8.3.x, но если вы переходите с версии до 8.3.1, следуйте инструкциям к 8.3.1
  • Selta:
обновление баз не требуется, для всех, кто переходит с версий 8.3.x. Если вы обновились с версии до 8.3, следуйте инструкциям Selta 8.3



Release 8.3.1

(поддерживается начиная с Selta 1.0.5)

  • Postgre:
Операция dump/restore не требуется для всех, кто переходит с версий 8.3.x. Однако вам может понадобится переиндексировать текстовые поля после обновления.
  • Selta:
обновление баз не требуется, для всех, кто переходит с версий 8.3.x. Если вы обновились с версии до 8.3, следуйте инструкциям Selta 8.3


Release 8.3

(поддерживается начиная с Selta 1.0.5)

  • Postgre, Selta:
Для корректной работы требуются выполнить операции
автоматически:Операции необходимые для перехода к версии postgreSQL 8.3
независимо от того, обновляли ли вы версию Selta, обязательно сделайте обновление ваших баз:
На клиентской машине запустите графическую утилиту SELTA ( Общее описание ), в главном меню выберите пункт Инициализация БД, и обновите ранее созданные базы до новой версии SELTA (подробнее в разделе Инициализация баз данных), или создайте новые.



Release 8.2.11-8.2.8

  • Postgre:
Операция dump/restore не требуется для всех, кто переходит с весий 8.2.x.
Однако, если вы переходите с версии до 8.2.7, следуйте инструкциям 8.2.7


Release 8.2.7 - ...

  • Postgre:
Операция dump/restore не требуется для всех, кто переходит с версий 8.2.x, но вам может понадобится переиндексировать текстовые поля после обновления.